Strange behavior v3

Some tips to resolve problems with the T-WATCH-2020
brannik
Posts: 13
Joined: Tue Apr 13, 2021 8:45 pm

Re: Strange behavior v3

Post by brannik »

so for now - Motor Accelerometer Bluetooth and Debug options are enabled, updated truth wifi and is working prety nice. Ty for your time <3
there is the log

Code: Select all

do_sleep
4069456
01
02
03
04
05
06
07
08
saved!!!
09
10
11
14
15
16
17
19
20
21
no repeating actions just turn off once and thats it untill button is pressed
mchavez
Site Admin
Posts: 84
Joined: Tue Nov 10, 2020 12:12 am

Re: Strange behavior v3

Post by mchavez »

Please confirm, the error is gone and your watch is working fine now? :shock:
brannik
Posts: 13
Joined: Tue Apr 13, 2021 8:45 pm

Re: Strange behavior v3

Post by brannik »

Yes is working carying it whole day all is fine. Even installed my app and is working good
CrimsonWraith
Posts: 4
Joined: Sat Jun 05, 2021 7:30 pm

Re: Strange behavior v3

Post by CrimsonWraith »

I had a similar problem on my v1. I tried some of the things done here and got it working. But the alarm app wasn't working, so I went in and turned alarm back on. This started my watch cycling again. Turned it off, gone. Could something with the RTC Alarm setting be causing the watch to reawaken immediately?
mchavez
Site Admin
Posts: 84
Joined: Tue Nov 10, 2020 12:12 am

Re: Strange behavior v3

Post by mchavez »

Could you please do a "Build All" with "Debug" and "Alarm" options checked and post the serial log to see what is happening?
CrimsonWraith
Posts: 4
Joined: Sat Jun 05, 2021 7:30 pm

Re: Strange behavior v3

Post by CrimsonWraith »

This is what I am getting

Code: Select all

09:11:07.764 -> do_sleep
09:11:07.764 -> 4071124
09:11:07.764 -> 01
09:11:07.764 -> 02
09:11:07.764 -> 03
09:11:07.764 -> 03a
09:11:07.764 -> 04
09:11:07.764 -> 05
09:11:07.764 -> 06
09:11:07.764 -> 07
09:11:07.764 -> 08
09:11:07.831 -> saved!!!
09:11:07.831 -> 09
09:11:07.831 -> 10
09:11:07.831 -> 11
09:11:07.831 -> 14
09:11:07.831 -> 15
09:11:07.831 -> 16
09:11:07.831 -> 18
09:11:07.831 -> 19
09:11:07.831 -> 21
09:11:07.831 -> sleeping!!
09:11:07.831 -> light sleep OK
09:11:07.831 -> do_sleep
09:11:07.831 -> 4248392
09:11:07.831 -> waking up
09:11:07.831 -> 23
09:11:07.831 -> 24
09:11:07.831 -> 25
09:11:07.831 -> 26
09:11:07.831 -> 27
09:11:07.831 -> 28
09:11:07.831 -> 29
09:11:07.831 -> 30
09:11:07.831 -> 31
09:11:07.831 -> 32
09:11:07.831 -> 32a
09:11:07.831 -> 33
09:11:07.831 -> 35
-Edit-
Okay, now it is fine. I was messing with the Alarm app to see if it would still go off while it was resetting, and it stopped resetting.
Here is my new output:

Code: Select all

09:17:05.249 -> do_sleep
09:17:05.249 -> 4070808
09:17:05.249 -> 01
09:17:05.249 -> 02
09:17:05.249 -> 03
09:17:05.249 -> 03a
09:17:05.249 -> 04
09:17:05.249 -> 05
09:17:05.249 -> 06
09:17:05.249 -> 07
09:17:05.249 -> 08
09:17:05.249 -> saved!!!
09:17:05.249 -> 09
09:17:05.249 -> 10
09:17:05.249 -> 11
09:17:05.249 -> 14
09:17:05.329 -> 15
mchavez
Site Admin
Posts: 84
Joined: Tue Nov 10, 2020 12:12 am

Re: Strange behavior v3

Post by mchavez »

We believe in some devices the alarm has some invalid values when not configured.
Could you run into the "Alarm" app, enable the alarm and then disable it? The problem remains?
CrimsonWraith
Posts: 4
Joined: Sat Jun 05, 2021 7:30 pm

Re: Strange behavior v3

Post by CrimsonWraith »

I disabled it, enabled, removed it from the watch, reinstalled it, tried disabling and re-enabling again. I can't seem to get it to start resetting again.
mchavez
Site Admin
Posts: 84
Joined: Tue Nov 10, 2020 12:12 am

Re: Strange behavior v3

Post by mchavez »

So the problem was solved?
We released a minor fix that disable alarm when not active, we think this was the cause of the problem
Post Reply