"Update failed" message (SOLVED)

Some tips to resolve problems with the T-WATCH-2020
Post Reply
Site Admin
Posts: 84
Joined: Tue Nov 10, 2020 12:12 am

"Update failed" message (SOLVED)

Post by mchavez »

NOTE: At this time we believe we have fixed the problem with the new firmware version 1.0.3. In our test it works very well, please try

If you have been experiencing problems with the watch's "Updater" app - showing the "Update failed" message - read the next info.

This problem happens because timeout issues between the watch's WiFi connection and our server. Sadly we cannot found yet a robust workaround for this problem because is related to the core libraries of the ESP32 with low timeout settings that cannot be changed (HTTPUpdate class). The problem seems to be worst over SSL connections (like our server).

There is an alternate solution is to install the apps using the serial port, in the same way you installed the first firmware. To do so follow the next steps:
  • Download the https://twatchbuilder.com/uploader.zip file has indicated in the "Get Started" page and decompress its content in a folder
  • Edit the included "downloader.bat" file and change the "X"s in first line with your device's ID (has showed in your watch "Settings/Information/Device ID")
  • Execute the "downloader.bat" file who will download your last compiled firmware and replace the older ones
  • Execute the "uploader.bat" file to install the new downloaded firmware on your watch
NOTE: The "downloader.bat" script uses the "curl" command that would be available in Windows 10. If not, please download and install it from https://curl.se/download.html

We will continue searching for a better solution for this problem.

The TWatchBuilder Team
Post Reply