Page 2 of 2

Re: Strange behavior v3

Posted: Wed May 26, 2021 11:57 pm
by brannik
so for now - Motor Accelerometer Bluetooth and Debug options are enabled, updated truth wifi and is working prety nice. Ty for your time <3
there is the log

Code: Select all

do_sleep
4069456
01
02
03
04
05
06
07
08
saved!!!
09
10
11
14
15
16
17
19
20
21
no repeating actions just turn off once and thats it untill button is pressed

Re: Strange behavior v3

Posted: Thu May 27, 2021 3:01 am
by mchavez
Please confirm, the error is gone and your watch is working fine now? :shock:

Re: Strange behavior v3

Posted: Thu May 27, 2021 5:09 pm
by brannik
Yes is working carying it whole day all is fine. Even installed my app and is working good

Re: Strange behavior v3

Posted: Mon Jun 14, 2021 7:11 pm
by CrimsonWraith
I had a similar problem on my v1. I tried some of the things done here and got it working. But the alarm app wasn't working, so I went in and turned alarm back on. This started my watch cycling again. Turned it off, gone. Could something with the RTC Alarm setting be causing the watch to reawaken immediately?

Re: Strange behavior v3

Posted: Mon Jun 14, 2021 9:25 pm
by mchavez
Could you please do a "Build All" with "Debug" and "Alarm" options checked and post the serial log to see what is happening?

Re: Strange behavior v3

Posted: Wed Jun 16, 2021 3:12 pm
by CrimsonWraith
This is what I am getting

Code: Select all

09:11:07.764 -> do_sleep
09:11:07.764 -> 4071124
09:11:07.764 -> 01
09:11:07.764 -> 02
09:11:07.764 -> 03
09:11:07.764 -> 03a
09:11:07.764 -> 04
09:11:07.764 -> 05
09:11:07.764 -> 06
09:11:07.764 -> 07
09:11:07.764 -> 08
09:11:07.831 -> saved!!!
09:11:07.831 -> 09
09:11:07.831 -> 10
09:11:07.831 -> 11
09:11:07.831 -> 14
09:11:07.831 -> 15
09:11:07.831 -> 16
09:11:07.831 -> 18
09:11:07.831 -> 19
09:11:07.831 -> 21
09:11:07.831 -> sleeping!!
09:11:07.831 -> light sleep OK
09:11:07.831 -> do_sleep
09:11:07.831 -> 4248392
09:11:07.831 -> waking up
09:11:07.831 -> 23
09:11:07.831 -> 24
09:11:07.831 -> 25
09:11:07.831 -> 26
09:11:07.831 -> 27
09:11:07.831 -> 28
09:11:07.831 -> 29
09:11:07.831 -> 30
09:11:07.831 -> 31
09:11:07.831 -> 32
09:11:07.831 -> 32a
09:11:07.831 -> 33
09:11:07.831 -> 35
-Edit-
Okay, now it is fine. I was messing with the Alarm app to see if it would still go off while it was resetting, and it stopped resetting.
Here is my new output:

Code: Select all

09:17:05.249 -> do_sleep
09:17:05.249 -> 4070808
09:17:05.249 -> 01
09:17:05.249 -> 02
09:17:05.249 -> 03
09:17:05.249 -> 03a
09:17:05.249 -> 04
09:17:05.249 -> 05
09:17:05.249 -> 06
09:17:05.249 -> 07
09:17:05.249 -> 08
09:17:05.249 -> saved!!!
09:17:05.249 -> 09
09:17:05.249 -> 10
09:17:05.249 -> 11
09:17:05.249 -> 14
09:17:05.329 -> 15

Re: Strange behavior v3

Posted: Wed Jun 16, 2021 3:35 pm
by mchavez
We believe in some devices the alarm has some invalid values when not configured.
Could you run into the "Alarm" app, enable the alarm and then disable it? The problem remains?

Re: Strange behavior v3

Posted: Thu Jun 17, 2021 3:38 am
by CrimsonWraith
I disabled it, enabled, removed it from the watch, reinstalled it, tried disabling and re-enabling again. I can't seem to get it to start resetting again.

Re: Strange behavior v3

Posted: Thu Jun 17, 2021 9:14 pm
by mchavez
So the problem was solved?
We released a minor fix that disable alarm when not active, we think this was the cause of the problem